2021/07/21 WordPressが「5.8」にバージョンアップ

WordPressプラグイン:テーマやプラグインのPHPバージョン互換性をチェック「PHP Compatibility Checker」

WordPressプラグイン:テーマやプラグインのPHPバージョン互換性をチェック「PHP Compatibility Checker」

PHP Compatibility Checker」はPHPバージョンの互換性をチェックするプラグインです。

WordPressのテーマやプラグインが、特定のPHPのバージョンで正常に動作するのかを調べてくれます。

サーバのPHPをバージョンアップする時などに重宝します。

PHP Compatibility Checker

最近のサーバは7系のPHPバージョンが普通ですが、ちょい前までは5系が主流でした。

で、いざバージョンアップをすると、急に一部のプラグインが動かなくなったり、サイトが真っ白になったり、なんてこともあり得ます。

それを事前にチェックできるのが、このプラグインです。

今回はPHPバージョン5.6のサーバにあるWordPressサイトで試してみました。

~ 目次 ~

  • インストールと有効化
  • PHPバージョンの互換性をチェック

インストールと有効化

WordPress管理画面より「プラグイン」⇒「新規追加」、
検索欄にて「PHP Compatibility Checker」で探します。

で、インストールして有効化

PHPバージョンの互換性をチェック

WordPress管理画面より
ツール」⇒「PHP Compatibility Checker」をクリック。

設定画面が開くので、調べたいPHPのバージョンにチェックを入れ、スキャンボタンをクリック。
今回はサーバをPHP7.3にバージョンアップしても問題ないか調査します。

スキャンはそれなりに時間がかかります。
気長にお待ちください。

ちなみに、スキャン中の表示はこちら↓
(*プラグイン「コンタクトフォーム7」をスキャン中)

スキャンが終わると、

こういう感じで結果が表示されます。
オールOKでした!
(ブログ的には残念ですがw)

駄目な場合は、エラーメッセージが表示されます。

ただ、仮にエラーが出たとしても、こちらのホワイトリストにある5つのプラグインならば問題ないとのことです。

 

ken
このプラグイン、いろいろなWEB制作会社でも頼りにされているそうです。

 

関連記事

 

PRリンク

シェアしてね!